Kawasaki Brute Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Picked up a 13 750 the other week for a good price i hope $3300.and that ussualy means that it needs some love. When I looked at it i noticed the front end alignment was way off.it Had all new tierods and ends on it. Easy fix.
2wd light stays on for a few seconds then a quick flash to 4wd then back to 2wd. I'm thinking engine brake? Ordered knight delete kit hopefully this will solve the problem?
Been reading on the site and getting. Good information. Site is very helpful.And getting familiar with my new ride.
7987
20200709_195428_copy_780x1040.jpg
 

·
Super Moderator
Joined
·
1,104 Posts
Good looking Brute. On the 2wd/4x4 light, try engaging it while in neutral, and creep forward slowly. That should engage the 4x4. If not, you may have an issue with the servo in the front diff.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I have some parts off right now so can't try it right away. If it is the front actuator. What are your thoughts on the knight manual kit? Looks like they get big money for actuators. It is going to see alot of water and mud. Front diff is milky. So i am going to reseal it along with engine side drive shaft seal. Overall it sounds good. Alittle clutch rattle at idle. Off idle it disappears.had clutch cover off and everything looks pretty good. I think the shoes? Or buttons? May need replace.
 

·
Super Moderator
Joined
·
1,104 Posts
I have no direct experience with that kit, but I know the manual kits are popular with the mud guys. Constant exposure to mud and water can wreak havoc on electronics.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Also it has a red spring on primary clutch. It does seem to have some stall
Haven't found any info on spring colors and what they mean
I have no direct experience with that kit, but I know the manual kits are popular with the mud guys. Constant exposure to mud and water can wreak havoc on electronics.
It has a red primary clutch spring. I don't believe it is stock? Can't seem to find info on spring colors and what they Do?
 

·
Super Moderator
Joined
·
13,356 Posts
I think MIMB still has the spring chart under their clutching section. Next time I am there I'll see if it is and post a link here. Otherwise if you do have the RED EPI primary, you probably also have the RED secondary so she...was a mud machine and...someone didn't do their homework as effective in 2012 Kawasaki changed the clutches so all the old springs are wrong to use in the 12s and newer...even though EPI might say it's OK. VFJ (VForceJohn) is the only one that has developed springs precisely for the 2012+ machines. He's a bit hard to talk with these days says many people but...he knows his stuff.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Thanks for the good info(y).i did notice a higher stall than normal in the clutch.definatly more than the grizzly i had. The tourqe on this thing is great.
Only test rode it So far. Brought it home and started to go thru everything. Always check out the toys when i get them used. Have found some scary things.nuts bolts missing etc. I don't have a problem talking to hard to deal with people as long as they know there shat:poop:.
 
1 - 7 of 7 Posts
Top