Kawasaki Brute Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2012 Brute Force 750 surging half throttle
2012 efi Brute Force 750 4000km
swamp exhaust
power commander 5 (custom map vforce john)
Primary Red spring (vforce john)
K&N air filter with breather box hood with fine screen filter
Recently by bike when I go above 1/4 throttle it starts to surge. Same at idle and stopped. idle fines and at 1/4 throttle.
goto half throttle and it starts this consistent surge like its starving for fuel but its not a bog just surges up and down at same rate. I replaced fuel pump and dirty sock at 2500km and installed a tank sock. no issues until 4000km. I just tried 2 sets of plugs and removed the power commander in case its ignition issue but it does not sound like it. Does exactly same thing PC or not. Bought new pump and fuel sock pump and pressure rugulator, still same problem.

I have not done a fuel pressure test but the chances of my 2n d pump and the new one being faulty are very low as they are doing the exact same thing. I have run the bike with fuel cap off and with check valve off tank and no change.
also checked the butterflys valves and they open identically and and seat properly.


No snorkels on bike.



I removed airbox and check all vacuum hoses for integrity. Could I have a bad injector or dirty or a bad Air idle valve. Does this valve control the pressure through the whole rpm range as you increase throttle. Does the the 2012 have a throttle sensor that is out of whack. Faulty solenoid wire or solenoid as it increases voltage


I am getting stumped
 

·
Super Moderator
Joined
·
13,315 Posts
2012 Brute Force 750 surging half throttle
2012 efi Brute Force 750 4000km
swamp exhaust
power commander 5 (custom map vforce john)
Primary Red spring (vforce john)
K&N air filter with breather box hood with fine screen filter
Recently by bike when I go above 1/4 throttle it starts to surge. Same at idle and stopped. idle fines and at 1/4 throttle.
goto half throttle and it starts this consistent surge like its starving for fuel but its not a bog just surges up and down at same rate. I replaced fuel pump and dirty sock at 2500km and installed a tank sock. no issues until 4000km. I just tried 2 sets of plugs and removed the power commander in case its ignition issue but it does not sound like it. Does exactly same thing PC or not. Bought new pump and fuel sock pump and pressure rugulator, still same problem.

I have not done a fuel pressure test but the chances of my 2n d pump and the new one being faulty are very low as they are doing the exact same thing. I have run the bike with fuel cap off and with check valve off tank and no change.
also checked the butterflys valves and they open identically and and seat properly.


No snorkels on bike.



I removed airbox and check all vacuum hoses for integrity. Could I have a bad injector or dirty or a bad Air idle valve. Does this valve control the pressure through the whole rpm range as you increase throttle. Does the the 2012 have a throttle sensor that is out of whack. Faulty solenoid wire or solenoid as it increases voltage


I am getting stumped

Three things that need tested. 1-Yes, do test the fuel pressure and volume. 2-test the TPS (throttle position sensor). 3- Test the CPS (Pulse sensor/Crank Position Sensor). Also, inspect the throttle body boots for splits. And if that an EHS lid you are using on your airbox lid..those were found not to provide the correct amount of air for the carbed machines so probably not for the EFIs. Get rid if it. Everyone else has.
 
1 - 2 of 2 Posts
Top