Kawasaki Brute Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, I just bought a 2006 Brute Force 650 in Reno, NV and when I started it and rode it there it was fine. I brought it home to Sacramento, Ca now its idling rough and in low throttle both carbs are backfiring. Has anyone else had this issue? If so, how did you fix it?


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
13,746 Posts
Hello, I just bought a 2006 Brute Force 650 in Reno, NV and when I started it and rode it there it was fine. I brought it home to Sacramento, Ca now its idling rough and in low throttle both carbs are backfiring. Has anyone else had this issue? If so, how did you fix it?


Sent from my iPhone using Tapatalk
Well, if it was jetted for altitudes at or above 3900 feet you are not way too lean at sea level so..go back to the stock jets. The manual will tell you what it had new.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Well, if it was jetted for altitudes at or above 3900 feet you are not way too lean at sea level so..go back to the stock jets. The manual will tell you what it had new.


Ok thank you, if I take it out of state again I'll have to redo the jets? Is there aftermarket jets that will work in both low and high altitudes?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
I also have a 06 Brute Force 650 and I am having the same issue. I have already done a carb rebuild with matching stalk jets. I am the original owner. I have also cleaned and serviced the fuel sustem to include cleaning the inside of the fuel tank. I just replaced the spark plugs last night and still have the same issue. I am at a total loss and extremely frustrated
 
1 - 5 of 5 Posts
Top