Kawasaki Brute Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·


Welcome from South Florida. I am completely new to the forum world and owning a 4x4 for that matter. Idk if I am even posting this thread rigjht but if I am I could really use some help.

I just recently purchased a 2007 650i brute force. It' is snorkeled with custom tires, exhaust, clutch, belt, and other upgrades. I just took it out to Mudjams and the bike was an animal through the mud. When I was in the mud I went to put the bike into 4 wheel drive but I wasn't moving. I just found out that to operate 4 wheel drive you need to be moving from what I was told. As soon as I went in to 4 wheel drive the bike started making like a knocking noise which seem to be echoing from my right snorkel. Now im not mechanically inclined by any means so I don't even know where to begin. Also it seemed to have like a grayish smoke coming from the snorkel as well. Now the bike seems to be bogging out when I give it gas. Any ideas or suggestions?
 

·
Super Moderator
Joined
·
13,840 Posts
Welcome. So..
A- Never switch it into 4wd stopped and never when its already in a bind. Always before and between 2 and 12 mph in a neutral state with the throttle..not on or off power.

B- that won't have anything to do with the belt. Only the coupler assembly on the diff. You need to pull the belt cover and inspect. I'll bet you got something in there.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
07 650i making noise

I did pull the casing off. It's perfectly clean and shiny inside. From what I could tell didn't find a drop of water, dirt, or mud. The clutch wheel pushes in out perfectly. The belt looks perfect. Didn't see any rubbing or tears in the belt either. I didn't know what to do from there.

Thanks for the help
 

·
Super Moderator
Joined
·
13,840 Posts
When the belt starts separating and loosing cogs, it makes a sound like something inside the cover is tapping on it so roll the belt all the way around inspecting every inch for the start of anything that looks like this. Check both sides all the way around.




 

·
Registered
Joined
·
951 Posts
that looks like my dayco belts
be sure an run only oem brute or t/rex belts ,all these so called super belts are just sh-t , we have tryed the all
 

·
Super Moderator
Joined
·
13,840 Posts
that looks like my dayco belts
be sure an run only oem brute or t/rex belts ,all these so called super belts are just sh-t , we have tryed the all
Yeah that was my first...and last Dayco belt. 20 miles is all I got out of it. A Carlisle did the same thing in just under a 100.
 
1 - 6 of 6 Posts
Top