Kawasaki Brute Forum banner
41 - 60 of 76 Posts

·
Administrator
Joined
·
14,588 Posts
So I finally got my brute to my shop….compression is at 120psi on both….plugs out and throttle wide open??? Manual says 33-65? I’m not understanding this.
If the compression release are working it would be in that 33-66 range. If someone put aftermarket cams in it, it may not have comp releases and it would be up in the 120+ range.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #42 ·
Im such a dumbass….. I just read through my build notes and in 2010….I put in cams that were welded and reground for higher lift and the decomp was eliminated. Stock pistons, timing. My shity comp gauge must be out. Going to borrow my brothers stock CDI from his 2009 (carb 1st gen) Teryx.
I’m hoping it’s the same and fires up.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #43 ·
Sooooo my brothers CDI is not the same and I don’t know anyone with another to rule out mine. I’m going to clean the carbs. At this point I’m at a loss….I have no idea why it won’t start.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #45 ·
I have been going over the connections will check the kill. As I understand it the roll-over sensor kills spark and fuel and I have both. Is it possible that the floats are stuck or out of adjustment and it keeps flooding? Plugs are wet when I take them out....
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #47 ·
So I took the carb off to inspect and clean up and I found that my choke cable was completely filled with fine dirt and stuck open. Took a lot to get the cables to move. Last year they were operating normally and they were operating at the lever on the bars. I must not of had the rubber boot on where it splits into two cables and that was packed full.

I ordered new cable, belt and end boots for the choke into the carb
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #49 ·
So I changed out the CDI to a Dynatek and it starts right up. Only issue I have now is I can see it backfire through the front carb…… anyone with an idea where to start for that now?

I also got to Dynatek coils to mount I wish the one end had a clamp instead of a zip tie…. Anybody come up with something better?
 

·
Administrator
Joined
·
14,588 Posts
So I changed out the CDI to a Dynatek and it starts right up. Only issue I have now is I can see it backfire through the front carb…… anyone with an idea where to start for that now?
The Dynatek CDI will advance the spark timing by about an additional 5 degrees. Any leaning problems or valve issues will show up worse as well as trying to run it without the air box lid on it...that will really make it pop back through the carbs. Ensure the air box is on and lid sealed. Ensure there is no splits on the carb boots..which usually end up being at or under the head-side clamps, and that the valves are set correctly. Also, you will need to go to the #40 pilot jets in the carbs from the stock #38s and at least install .030-.040 shims on the CV slide main needles. After that it will be a matter of setting the A/Fs to the correct idle mixture ratio which should be around 2.2 - 2.5 turns out from closed.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #52 · (Edited)
Carb rear #155 front #160 with 1 shim on each needle, #42 pilots already in (don’t have 40’s) and floats set to 4-5mm. Front float was 3mm. A/F 2 1/4 turns. YZF450 crank pressure tank was split along the seam so cleaned that up and glued. Didn’t like how the Dyna coils mounted in the instructions so fabed up some mounts and welded on in the same locations.

Next is front knuckle tie rod slop

Everyone have a great weekend.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #58 ·
Sooooo…..took the shock of the knuckle to check out the ball joints and when I lift up slightly the knuckle moves smoothly…..is it possible the Elkas travel has the knuckle just to its limit and causing the ball joints to bind? Rubber boots are not torn, grease did come out the top one and the stem wants to stay leaning out in its bolted position.
I have no experience with these so just explaining what I see.
 
41 - 60 of 76 Posts
Top