Kawasaki Brute Forum banner

fuel

  1. 2012 BF 750 4x4 stopped running and dies after 3 seconds

    Brute Chassis & Electrical
    Just Joined for help (Thanks in advance). ATV is babied... Changed the oil 2 months ago and after a couple weeks it just died. Starts up but dies after 3 seconds once it goes into run (normal) mode. When I turn the key on all the lights come on for 3 seconds and then the EPS is solid and the...
  2. 2011 750 Brute fuel pump

    Brute Chassis & Electrical
    Hey guys, new to the forum. I just picked up a '10 750 brute that the fuel pump relay is gone and the jumper on it to make the pump run constantly. Bike runs fine like that but obviously not how it needs to be left. I have a '11 750 that everything works fine that I can swap parts to figure...
  3. No start... Can hear fuel pump running ideas???

    Brute Engine & Drivetrain
    09 brute ran great for a whole derby... Day later starts sputtering around 50-60 km per hr made it home sat over night now no start but we can here the fuel pump.. New plugs clean filter, I did run it a pretty low on fuel as we kinda go side tracked on the way home" happens" any ideas much...
  4. Crank, but no start after sitting,

    Brute Engine & Drivetrain
    I have a 2009 750i and love it until today after sitting in the shop for a week went to start it and just cranks, I can't hear the noise from the fuel pump I usually do.... Ran great before I parked it... Any idea would be much appreciated I check all the basics fuses and plugs and such..... So...
Top