Kawasaki Brute Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. Brute Talk
    2008 Kawasaki 650 4x4i (This is NOT fuel injected) Has been running fine for a year. All of a sudden this morning, I went to give it some throttle while out and about, and it died after it acted like it was completely starving for fuel. It starts and idles fine but as soon as you give it some...
  2. Brute Chassis & Electrical
    I have already replaced the entire harness, the fuse box, the fuel pump, all the relays, and the rollover switch as well. When I jump the relay the pump runs. When I plug in the relay the pump will not come on. Any help would be greatly appreciated.
  3. Brute Talk
    I started my 2012 brute force 750 the other day and was going to let it warm up and after about ten seconds it shut off and now just spins. When i turn the key to on i hear 2 short buzzes which seem to come from just underneath the air filter box i googled it people said it might me the fuel...
  4. Brute Engine & Drivetrain
    I just did a full engine rebuild on my 05 Brute Force 750 due to my cam gear exploding. The bike would even start after that. So now that I have it all back together it wont start. It will start with starter fluid but its not getting fuel. I pulled the fuel line off the carb and turned the key...
  5. Brute Engine & Drivetrain
    Just did an inline fuel pump test and the gauge climbs to 45 psi instantly but it slowly drops off to 0. Tried searching the forum already but found no straight answer to whether there is a regulator or anything or what the problem could be. Thanks for any input from anyone who might know.
  6. New Member Introductions
    New member, first post. I'm having trouble with my fuel pump and fan relays. They aren't closing. The wires were corroded and loose causing intermittent issues in both so I cut and spliced new connectors in. I also replaced the fan breaker with an inline fuse. Both relays are getting voltage to...
  7. Brute Chassis & Electrical
    The wiring on my 2011 Brute 750 became corroded and came out of the two relays on the rear of the bike under the seat. Wondering if off hand anyone knew the order they went in or could possibly look at theirs and tell me how they go. Should be the same on Brutes 08-11. Each of the two relays...
  8. Brute Engine & Drivetrain
    Have a 2011 Brute and cant get any fuel to pump out of the fuel line that goes into the throttle body, Noticed this as I couldn't get the bike to start. Checked the spark and battery (battery is bran new), engine turns over aok. So ultimately I cant get any fuel to pump, checked and replaced...
1-8 of 8 Results
Top