Kawasaki Brute Forum - Reply to Topic
Thread: Battery, now belt.. Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
September 11th, 2019 01:02 PM
dman66 PROBABLY WEAK BATTERY - OR VOLTAGE REGULATOR IS DEFECTIVE.
PUT A VOLT METER ON THE BATTERY AND TEST FOR VOLTAGE - SHOULD HAVE 12.6 WITH NOTHING ON - 13.8 - 14 VOLTS DC WHILE RUNNING
September 7th, 2019 09:57 PM
NMKAWIERIDER Probably the battery but it's erratic voltages, spikes and open batterys like that that take out ECUs...and they quit giving them away a while back...lol. Find and fix the power problem first and your light may just go away...unless...the ECU is now toast.
September 7th, 2019 08:52 PM
eveibz
Battery, now belt..

So belt light comes on my 750 few weeks ago and changed it out, reset the light no problems. Go out today starts fine, ride 20 min and turn it off dead. Not even a number on the screen. Boost it over and over, soon as the cables come off thing dies. Finally get it going but now it's in limp mode, the belt light flashing and dies 100ft up the trail. Towed back to the truck. My guess is new battery lol but the belt?? Why flashing again and limp???

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome