Kawasaki Brute Forum - Reply to Topic
Thread: Break in Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
March 17th, 2019 02:23 PM
Rokmonanoff
Quote:
Originally Posted by Rileyz View Post
I got a 2019 brute Force 750 eps still breaking it in with maybe 15 miles so far. The steering feels a little stiff for eps just wondering if it's gotta break in also?


Shouldn’t be a breakin period. I’ve had the PS fuse go out on other machines. Did you check that?


Sent from my iPad using Tapatalk
February 7th, 2019 10:54 AM
NMKAWIERIDER
Quote:
Originally Posted by Rileyz View Post
I got a 2019 brute Force 750 eps still breaking it in with maybe 15 miles so far. The steering feels a little stiff for eps just wondering if it's gotta break in also?
Shouldn't..nothing to wear-in. Some have had issues with the PS unit or controller so might take it in and see.
February 6th, 2019 09:58 PM
Rileyz
Break in

I got a 2019 brute Force 750 eps still breaking it in with maybe 15 miles so far. The steering feels a little stiff for eps just wondering if it's gotta break in also?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome