2012 - Kawasaki Brute Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old April 14th, 2019, 04:07 PM Thread Starter
 
Join Date: Apr 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2012

I got a 2012 brute force 750 running 29.5 outlaw 2s my batterie isn’t taking any charge while running and the EPS light come on and that’s my signal to put the battery back on charge any ideas what’s going on
Jonathon51 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old April 14th, 2019, 05:11 PM
 
NMKAWIERIDER's Avatar
 
Join Date: Aug 2008
Location: Albuquerque, NM
Posts: 12,947
Thanks: 5
Thanked 690 Times in 642 Posts
Garage
Quote:
Originally Posted by Jonathon51 View Post
I got a 2012 brute force 750 running 29.5 outlaw 2s my batterie isnít taking any charge while running and the EPS light come on and thatís my signal to put the battery back on charge any ideas whatís going on
Simple. Failed charging system. It's either the stator or the rectifier/regulator. The manual will show you how to test each. Most often, it's been a failed winding in the stator.

15 Z Force 800 EFI
06 BF 750 (SOLD)

My Videos On You Tube
NMKAWIERIDER is online now  
Reply

  Lower Navigation
Go Back   Kawasaki Brute Forum > BC News & Site Info > New Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome