05 Brute Force 750 won't stay on - Kawasaki Brute Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old October 7th, 2019, 12:33 PM Thread Starter
 
Join Date: Oct 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question 05 Brute Force 750 won't stay on

Hi Everyone, first time poster long time forum reader. I have an 05' BF 750 that I absolutely love and is kept stock except for some awesome handle bar grips haha! I bought her two years ago and has been running great except for this past weekend.



After a long muddy weekend riding in upstate NY my Brute will no longer idle. I can start her up and keep her running as long as I feather the throttle, but if I let off the gas she dies out. I know she isn't perfect, but I never had this issue previously and now wondering where to start. I noticed the choke lever seems to be a little loose or not as tight as it once was. I also noticed I've been riding her for two years with out a "Screw-Throttle Stop" (Part - 16021). I'm not sure what this part does but I know when I bought the bike it wasn't included, odd.


I have a feeling it's something related with the carburetor but not sure where to begin and definitely don't want to damage it any further. Sorry in advance for being vague and any help would be greatly appreciated! Thank you!
Tim Cullen is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old October 7th, 2019, 03:50 PM
 
NMKAWIERIDER's Avatar
 
Join Date: Aug 2008
Location: Albuquerque, NM
Posts: 13,046
Thanks: 5
Thanked 693 Times in 645 Posts
Garage
Check all the normal things like electrical connections, carb boots for splits, connections under the fuse box for corrosion, Its an 05 so it has the bad buss connector issue..a must to fix, Fuel supply, drain the carb bowels for water..very common, check voltage at battery and coils-check that the charging system is working correctly, check the valve lash..too tight will stop them from idling for sure. Things like that.

15 Z Force 800 EFI
06 BF 750 (SOLD)

My Videos On You Tube
NMKAWIERIDER is online now  
Reply

  Lower Navigation
Go Back   Kawasaki Brute Forum > Brute Forums > Brute Engine & Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome