Bogging?! - Kawasaki Brute Forum
 1Likes
  • 1 Post By NMKAWIERIDER
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old June 17th, 2018, 08:48 AM Thread Starter
 
Chevrolettough's Avatar
 
Join Date: Nov 2014
Location: Wisconsin
Posts: 265
Thanks: 23
Thanked 5 Times in 5 Posts
Garage
Bogging?!

So... no good. 2008 Kawasaki Brute 750i

Starts right up, but if i drive it or have it in neutral and rev it it falls on its face.

Somewhat recent upgrades but no issues for awhile with them on: HMF slip on and fuel optimizer. EPI secondary almond spring and new belt.

I have bypassed the fuel optimizer and it still does it.

Daughter rode it for quite awhile going super slow... wondering if a plug is bad. They are fairly new.

If I drive it and pin it from a stand still it dies also.

With the optimizer hooked up I can see it goes from green to red when revving (when it falls on its face). Fuel Econ appears to be awful too.




Sent from my iPhone using Tapatalk

2008 Kawaski Brute Force 750
- 26" Artrax tires w/ STI HD4 rims
- Superwinch LT3000 w/ synthetic rope
- HMF Exhaust, HMF Fuel Mapper
- Twin Air
- Halo eyes
- EPI Almond Secondary Spring
Chevrolettough is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old June 17th, 2018, 09:13 AM Thread Starter
 
Chevrolettough's Avatar
 
Join Date: Nov 2014
Location: Wisconsin
Posts: 265
Thanks: 23
Thanked 5 Times in 5 Posts
Garage
Iíll pull the plugs but maybe the fuel pump has decided to go? They look nice and cheap..


Sent from my iPhone using Tapatalk

2008 Kawaski Brute Force 750
- 26" Artrax tires w/ STI HD4 rims
- Superwinch LT3000 w/ synthetic rope
- HMF Exhaust, HMF Fuel Mapper
- Twin Air
- Halo eyes
- EPI Almond Secondary Spring
Chevrolettough is offline  
post #3 of 5 Old June 17th, 2018, 09:22 AM Thread Starter
 
Chevrolettough's Avatar
 
Join Date: Nov 2014
Location: Wisconsin
Posts: 265
Thanks: 23
Thanked 5 Times in 5 Posts
Garage
Bogging?!

Ok... who wants a funny story??

So I cleaned the intake box... left a rag UNDER the screen. I just went out to clean the air filter and check a few more things. My god!!! *slaps forehead*


Sent from my iPhone using Tapatalk

2008 Kawaski Brute Force 750
- 26" Artrax tires w/ STI HD4 rims
- Superwinch LT3000 w/ synthetic rope
- HMF Exhaust, HMF Fuel Mapper
- Twin Air
- Halo eyes
- EPI Almond Secondary Spring

Last edited by Chevrolettough; June 17th, 2018 at 09:22 PM.
Chevrolettough is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old June 17th, 2018, 09:37 AM
 
NMKAWIERIDER's Avatar
 
Join Date: Aug 2008
Location: Albuquerque, NM
Posts: 12,986
Thanks: 5
Thanked 692 Times in 644 Posts
Garage
Wow...well...that'll do it.
Chevrolettough likes this.

15 Z Force 800 EFI
06 BF 750 (SOLD)

My Videos On You Tube

Last edited by NMKAWIERIDER; June 17th, 2018 at 03:55 PM.
NMKAWIERIDER is online now  
post #5 of 5 Old June 17th, 2018, 09:23 PM Thread Starter
 
Chevrolettough's Avatar
 
Join Date: Nov 2014
Location: Wisconsin
Posts: 265
Thanks: 23
Thanked 5 Times in 5 Posts
Garage
Bogging?!

Quote:
Originally Posted by NMKAWIERIDER View Post
Wow...well...that'll do it.


I feel like a complete moron!


Sent from my iPhone using Tapatalk

2008 Kawaski Brute Force 750
- 26" Artrax tires w/ STI HD4 rims
- Superwinch LT3000 w/ synthetic rope
- HMF Exhaust, HMF Fuel Mapper
- Twin Air
- Halo eyes
- EPI Almond Secondary Spring
Chevrolettough is offline  
Reply

  Lower Navigation
Go Back   Kawasaki Brute Forum > Brute Forums > Brute Engine & Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome