750 ECM - Kawasaki Brute Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old January 3rd, 2019, 04:47 PM Thread Starter
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
750 ECM

I bought a 2017 KVH750JHF at an auction . Whoever had it attempted to snorkel it. There was a piece of a vacuum hose for the intake, some other type hose for the cover vent, a real botched job. I also found a opened pocket knife and a pair of pliers in the wiring under the front cover. Anyway the ECM was tie wrapped to the steering post.

What I need to know is where the ECM is mounted, there is a post on one end and a hole for a bolt on the other. I know it goes in there somehow but can't seem to see where it goes. A pic of the ECM in the right place would help. I don't want to tie wrap back where it was, but the wires are short and not much place to go from where it is connected.

won't let me attach a jpeg.
skimmerboat is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old January 3rd, 2019, 05:50 PM
 
NMKAWIERIDER's Avatar
 
Join Date: Aug 2008
Location: Albuquerque, NM
Posts: 13,048
Thanks: 5
Thanked 693 Times in 645 Posts
Garage
Quote:
Originally Posted by skimmerboat View Post
I bought a 2017 KVH750JHF at an auction . Whoever had it attempted to snorkel it. There was a piece of a vacuum hose for the intake, some other type hose for the cover vent, a real botched job. I also found a opened pocket knife and a pair of pliers in the wiring under the front cover. Anyway the ECM was tie wrapped to the steering post.

What I need to know is where the ECM is mounted, there is a post on one end and a hole for a bolt on the other. I know it goes in there somehow but can't seem to see where it goes. A pic of the ECM in the right place would help. I don't want to tie wrap back where it was, but the wires are short and not much place to go from where it is connected.

won't let me attach a jpeg.
Yeah you need 5 post before you can upload anything. I suggest getting the shop manual or go to cheapcycleparts.com and look up the frame electronics. It will show where all things are.

15 Z Force 800 EFI
06 BF 750 (SOLD)

My Videos On You Tube
NMKAWIERIDER is online now  
post #3 of 3 Old January 6th, 2019, 01:09 PM Thread Starter
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Finally found it on partzilla. The bracket that holds the ECM ESP was missing. It was under the steering section for some reason. $50 of parts will keep the $600 ESP from bouncing around!
skimmerboat is offline  
Reply

  Lower Navigation
Go Back   Kawasaki Brute Forum > Brute Forums > Brute Chassis & Electrical

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome