2 new Brute forces broke down in one weekend - Kawasaki Brute Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old May 19th, 2008, 07:12 PM Thread Starter
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
2 new Brute forces broke down in one weekend

Weekend started out great :yeahbaby01: until we had problems :cussing: . My Buddies Wife's new 07 BF 650 started drinking anti freeze no signs of leaks and no white smoke out of the exhaust??? Then mine was next 2008 BF 750 with only 73km on it and the fellow riding behind me (on a 1500.00 dollar quad he bought which out lasted ours) stopped me and said he had noted oil on the road where we had stopped last. Checked it out and there was an oil and coolant mix coming out of my coolant over flow tube. I pulled the coolant tank cap and sure enough it was full of a milky oil and anti freeze mixture. It smells strong like gear oil I am not sure how the gear and coolant oil are related unless it uses the same cooler??? Engine oil is also down a bit too. Any ideas on what could be wrong with either the 650 or mine the 750. is this a common problem with the Brute Forces? I guess they will be going back to the dealers tomorrow. :deal:
Toeknee is offline  
post #2 of 5 Old May 19th, 2008, 08:51 PM
 
BruteJockey's Avatar
 
Join Date: Apr 2007
Location: Saskatchewan, Canada
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
2 new Brute forces broke down in one weekend

I don't have no fix for you but no that's not common!! You both had a run of really bad luck that's what that is!! Sorry to hear about that!

'06 Brute Force 650 4x4i
26" Maxxis Bighorns, 12" ITP SS 106,
Direction 2 Overfenders, Diamond Bumper,
Floor Board Trim, Engraved Billet Shifter,
Copperhead VDI, Full Muzzy Exhaust, DynoJet kit
Clutch Springs (EPI maroon primary, stock secondary)
Intake Splash Guard, Swaybar Removed....
BruteJockey is offline  
post #3 of 5 Old May 20th, 2008, 03:28 PM
 
Join Date: Oct 2006
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
2 new Brute forces broke down in one weekend

I have never heard of that happening either. WOW.

2007 Brute Force 750
2007 DRZ 400
www.myspace.com/bacord
Follow me on SPOT TRACKER
Seca_ is offline  
post #4 of 5 Old May 20th, 2008, 10:37 PM Thread Starter
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
2 new Brute forces broke down in one weekend

I dropped it off at the dealer today and they have never heard of that either. I guess time will tell once they get it opened up to have a better look at it. I will keep you posted on the out come
Toeknee is offline  
post #5 of 5 Old May 21st, 2008, 12:20 AM
 
BruteJockey's Avatar
 
Join Date: Apr 2007
Location: Saskatchewan, Canada
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
2 new Brute forces broke down in one weekend

Yes, keep us posted!

'06 Brute Force 650 4x4i
26" Maxxis Bighorns, 12" ITP SS 106,
Direction 2 Overfenders, Diamond Bumper,
Floor Board Trim, Engraved Billet Shifter,
Copperhead VDI, Full Muzzy Exhaust, DynoJet kit
Clutch Springs (EPI maroon primary, stock secondary)
Intake Splash Guard, Swaybar Removed....
BruteJockey is offline  
Reply

  Lower Navigation
Go Back   Kawasaki Brute Forum > Brute Forums > Brute Engine & Drivetrain

Quick Reply
Message:
Options



In order to be able to post messages on the Kawasaki Brute Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
It Broke Mart1 Brute Chassis & Electrical 27 February 14th, 2007 12:58 AM
Hello Fellow V-forces Riderz... NEw here Trey TheV-force RideR General Discussion 5 November 1st, 2006 12:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome