Brute Central Forums
Home | Forums | Garage | Premium
Top Banner 1
Quick Member Login:
Forgot password?

Cool Stuff:
Go Premium

Sponsor Us
Forum Statistics:
Forum Members: 8,960
Total Threads: 8,149
Total Posts: 67,247

You don't appear to be registered. Click here to register
Search the forums:
Old April 11th, 2010, 08:49 PM   #1
 
The Great Pumpkin's Avatar
 
Join Date: Oct 2009
Location: Welland On
Posts: 49
Thanks: 6
Thanked 0 Times in 0 Posts
Default Idle Problem

Hello having a prob with the brute, 650, when she is running on a idle its missing and popping out of the carb when you add some choke and just it gas it seems to clear up ,, when your riding it seems ok notice it starting a bit a couple times but now it seems to be much more steady, i didnt know if it was dirt in a carb, the quad just hit 550 km just broke it in...

any ideas thanks Gino
The Great Pumpkin is offline   Reply With Quote
Old April 11th, 2010, 09:28 PM   #2
 
NMKAWIERIDER's Avatar
 
Join Date: Aug 2008
Location: Albuquerque, NM
Posts: 9,746
Thanks: 5
Thanked 514 Times in 466 Posts
Default

Quote:
Originally Posted by The Great Pumpkin View Post
Hello having a prob with the brute, 650, when she is running on a idle its missing and popping out of the carb when you add some choke and just it gas it seems to clear up ,, when your riding it seems ok notice it starting a bit a couple times but now it seems to be much more steady, i didnt know if it was dirt in a carb, the quad just hit 550 km just broke it in...

any ideas thanks Gino
One very common problem is the carb boots. They split next to the clamps and suck in air. They also suck in dirt too! This make the mix lean and makes it pop back through the carb. Better check it. The other think is water in the bowls. Just drain them. Also, tight intake valves do that too.
__________________
06 750 (Silver)
EZ-Steer EPS | Elka Stage-3 Shocks | Dynatek CDI |UNIfilter Filter | Catch Can | Perma-Cool Oil Cooler | Diamond "G" Tie Rods w/Moose Ends | Energy Swaybar Bushings | OMI Stem Bushing | Ricochet Skid Plates | HL Bumper | Direction2 Overfenders | 26" Grim Reapers on 14" SS112s | 2012 Seat | 2013 A-Arms & Bushings| Shorai Battery | ROX Riser & guards | Tons More Stuff!


NMKAWIERIDER is online now   Reply With Quote
Old April 11th, 2010, 09:54 PM   #3
 
The Great Pumpkin's Avatar
 
Join Date: Oct 2009
Location: Welland On
Posts: 49
Thanks: 6
Thanked 0 Times in 0 Posts
Default

ok thanks i will jhave to take a look i was thinking dirt from all the sitting,,i will have a good look this week and get it sorted out
The Great Pumpkin is offline   Reply With Quote
Old September 25th, 2011, 08:50 PM   #4
 
Join Date: Sep 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

mine is doing the same thing. just had the vaules adjusted by the dealer...it has no mods and 101 hrs and 177 mile....2006 brute force 750
foxhillbrute750 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Brute Central Forums » Brute Forums » Brute Engine & Drivetrain


Search tags for this page
08 brute force 750 popping through intake at idle
,
2011 kawasaki brute force 750i engine idle problems
,
2012 brute force 750 idle adjustment
,
brute force 650 carb prob
,
brute force 650 poping thru carbs
,
brute force 750 popping carb at idle
,
brute force 750i idle issue
,

brute force idle problem

,

brute force idle problems

,
brute force popping pull choke it clears up
,
brute popping through carb
,
bruteforce650 poping out carb
Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:55 PM.

Website by Be Seen.


SEO by vBSEO ©2011, Crawlability, Inc.