Kawasaki Brute Forum
Home | Forums | Garage | Premium
Top Banner 1
Discount Tire
Quick Member Login:
Forgot password?

Cool Stuff:
Go Premium

Sponsor Us
Forum Statistics:
Forum Members: 9,099
Total Threads: 8,250
Total Posts: 68,036

You don't appear to be registered. Click here to register
Search the forums:
Old June 18th, 2008, 07:16 AM   #1
 
Join Date: Aug 2007
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

yesterday i noticed a pinging loose bolt kind of noise comming from the belt clutch housing. my belt light dosnt come on and the bike still rides ok. but if i put it in gear and get off of it she drives away on me, and the 2wd 4wd light is flashing back and forth, anybody had this problem before,
__________________
05 Brute 750: 11:5:1 JE PISTONS, WEBB CAMS, FULL MUZZY, VFJ STAGE 3 Clutch, 2" LIFT, COPPERHEAD, CENTRE SNORKLES, K&N, DYNO JET and DYNO TUNED. 2009 SUNBEAM RED PLASTICS. 28" ZILLAS, STAINLESS STEEL BRAKE LINES
BRICKLAYER is offline   Reply With Quote
Old June 18th, 2008, 07:18 AM   #2
 
Adirondack Man's Avatar
 
Join Date: Oct 2006
Location: West Chazy, NY
Posts: 3,021
Thanks: 4
Thanked 41 Times in 37 Posts
Default noise from clutch

You need to pull your clutch cover and take a look inside. The belt is a top cog design and sometimes the top cogs may start to seperate and peel off. If so, it would have tripped your belt sensor, and pieces of belt could be binding in the sheaves, causing the roll away condition. Let us know what you find.
__________________
'14 AC Wildcat Trail XT - My new ride...
'03 Prairie 650 - BKP 730 kit with 2X trail/race cams, MW oil cooler, DG Snorkle and EHS air box lid, Twin Air proflow filter, Rox Risers, Pro Taper bars, Works struts, VFJ Stage 3 spider mod clutch, lightened secondary, Goodyear MT/R's on Douglas Rattlesnakes, full Muzzy - SOLD, but will ALWAYS hold a special place in my heart!
'09 Polaris Sportsman 850XP - clutch kit, Duro Power Grip tires, Big Gun slip on
Adirondack Man is online now   Reply With Quote
Old June 18th, 2008, 07:56 AM   #3
 
Join Date: Aug 2007
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

the belt light hasnt came on yet, what about the 2wd 4wd flashing back and forth? and the bike running away when its in gear?
__________________
05 Brute 750: 11:5:1 JE PISTONS, WEBB CAMS, FULL MUZZY, VFJ STAGE 3 Clutch, 2" LIFT, COPPERHEAD, CENTRE SNORKLES, K&N, DYNO JET and DYNO TUNED. 2009 SUNBEAM RED PLASTICS. 28" ZILLAS, STAINLESS STEEL BRAKE LINES
BRICKLAYER is offline   Reply With Quote
Old June 18th, 2008, 04:09 PM   #4
 
Join Date: Aug 2007
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

took the belt cover off and there was nothing out of the ordinary clean as a whistle, took it to the dealer and he said it was the spider assembly it was worn out i guess, new one $157.00 not bad i guess, as for the 2wd 4wd flashing back and forth i have no idea what that can be anybody had that problem before im sure it must be electrical some what?
__________________
05 Brute 750: 11:5:1 JE PISTONS, WEBB CAMS, FULL MUZZY, VFJ STAGE 3 Clutch, 2" LIFT, COPPERHEAD, CENTRE SNORKLES, K&N, DYNO JET and DYNO TUNED. 2009 SUNBEAM RED PLASTICS. 28" ZILLAS, STAINLESS STEEL BRAKE LINES
BRICKLAYER is offline   Reply With Quote
Old June 18th, 2008, 05:04 PM   #5
 
Join Date: Mar 2008
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

Hmmm You know, I've noticed some hairline cracks in my spyder assembly and primary clutch spring cover as well. I wonder if that is what is causing my belt slippage and the noise I hear when I punch it while in water or mud in high gear.
Waterfreak66 is offline   Reply With Quote
Old June 18th, 2008, 09:03 PM   #6
 
Adirondack Man's Avatar
 
Join Date: Oct 2006
Location: West Chazy, NY
Posts: 3,021
Thanks: 4
Thanked 41 Times in 37 Posts
Default noise from clutch

2wd/4wd light could be your kebc actuator motor going bad. I completely removed the kebc fork from my clutch cover. Didn't need it after the vforcejohn stage 3 clutch with spider mod anyhow.
__________________
'14 AC Wildcat Trail XT - My new ride...
'03 Prairie 650 - BKP 730 kit with 2X trail/race cams, MW oil cooler, DG Snorkle and EHS air box lid, Twin Air proflow filter, Rox Risers, Pro Taper bars, Works struts, VFJ Stage 3 spider mod clutch, lightened secondary, Goodyear MT/R's on Douglas Rattlesnakes, full Muzzy - SOLD, but will ALWAYS hold a special place in my heart!
'09 Polaris Sportsman 850XP - clutch kit, Duro Power Grip tires, Big Gun slip on
Adirondack Man is online now   Reply With Quote
Old June 19th, 2008, 09:43 AM   #7
 
Join Date: Aug 2007
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

could i just remove mine without the mod what will it do without an engine brake?
__________________
05 Brute 750: 11:5:1 JE PISTONS, WEBB CAMS, FULL MUZZY, VFJ STAGE 3 Clutch, 2" LIFT, COPPERHEAD, CENTRE SNORKLES, K&N, DYNO JET and DYNO TUNED. 2009 SUNBEAM RED PLASTICS. 28" ZILLAS, STAINLESS STEEL BRAKE LINES
BRICKLAYER is offline   Reply With Quote
Old June 19th, 2008, 10:20 AM   #8
 
VTprairie's Avatar
 
Join Date: Dec 2006
Posts: 2,085
Thanks: 2
Thanked 7 Times in 6 Posts
Default noise from clutch

<div class='quotetop'></div>
Quote:
could i just remove mine without the mod what will it do without an engine brake?[/b][/b]

yes
__________________
2014 Polaris Touring LE 850XP
2014 Polaris RZR 800 LE
VTprairie is offline   Reply With Quote
Old June 23rd, 2008, 02:51 PM   #9
 
Join Date: Aug 2007
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

if i remove the fork is there going to be any change to the handling or braking to the bike will it be harder on belts, basically what will be the side effects, kawi must put that brake on for a reason,
__________________
05 Brute 750: 11:5:1 JE PISTONS, WEBB CAMS, FULL MUZZY, VFJ STAGE 3 Clutch, 2" LIFT, COPPERHEAD, CENTRE SNORKLES, K&N, DYNO JET and DYNO TUNED. 2009 SUNBEAM RED PLASTICS. 28" ZILLAS, STAINLESS STEEL BRAKE LINES
BRICKLAYER is offline   Reply With Quote
Old June 23rd, 2008, 06:47 PM   #10
 
Join Date: Jun 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default noise from clutch

Just rode mine yesterday for the first time since I removed the KEBC fork. Take it off, you'll never miss it. The engine brake works just like normal until you get down to about 5-8 mph then it completely lets go. The fork simply applies pressure to the belt at low speed to force it into contact with the clutch sheaves. Take it off and try it. If you don't like it put it back on. It only takes a few minutes to remove and re-install. I like mine without it better and I was told by Interstate Motorsports that belt life is better without it.
KawiBrute is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Kawasaki Brute Forum » Brute Forums » Brute Engine & Drivetrain


Search tags for this page
brute 750 noisy clutch
,
brute force 650 belt noise
,

brute force 650 clutch noise

,
brute force 750 belt noise
,

brute force 750 clutch noise

,

brute force clutch noise

,
bruteforce 750 clutch noise
,
changing clutches in a 650 brutte force
,

kawasaki brute force clutch noise

,
kawasaki brute force noise
,
kawasaki prairie 650 clutch noise
,

kawasaki prairie clutch noise

Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Noise? Dagan Brute Engine & Drivetrain 10 May 5th, 2009 11:23 PM
clutch noise bigdog77 Brute Engine & Drivetrain 1 December 24th, 2007 07:15 AM
Noise????? bruteboy101 Brute Engine & Drivetrain 1 March 9th, 2007 08:10 PM


All times are GMT -4. The time now is 09:14 AM.

Website by Be Seen.


SEO by vBSEO ©2011, Crawlability, Inc.