Brute Central Forums
Home | Forums | Garage | Premium
Top Banner 1
Quick Member Login:
Forgot password?

Cool Stuff:
Go Premium

Sponsor Us
Forum Statistics:
Forum Members: 8,956
Total Threads: 8,147
Total Posts: 67,243

You don't appear to be registered. Click here to register
Search the forums:

Brute Central Forums » Brute Forums » Brute Chassis & Electrical » Brute Force 750 steering problem

Reply
 
LinkBack Thread Tools Display Modes
Old August 29th, 2011, 10:23 PM   #1
 
Fordgasm250's Avatar
 
Join Date: Aug 2011
Location: Va
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Brute Force 750 steering problem

i have a 2012 750 brute eps.... my steering locked up on me less then 30 hrs on it, kawasaki had it for a month, thought it was the electric power steering, replaced it and still did it had a engineer come out and said it was the front diff lockin up, replaced that and i finally got it back and rode it 10 miles and it locked up on me again. They told me its the first time they have ever seen this or had this problem and i was wondering if anyone has seen it or heard of it........
__________________
2012 750 brute 14 in SS212 wheels, 27" itp terra cross, hmf swamp series exhaust, hmf efi optimizer, k&n filter
Fordgasm250 is offline   Reply With Quote
Old August 30th, 2011, 08:24 AM   #2
 
rmax's Avatar
 
Join Date: Jul 2010
Location: ne arkansas, south miss
Posts: 727
Thanks: 0
Thanked 27 Times in 27 Posts
Default

i do not know any thing about the sterring on the new ones ,an have not seen any post on other forums about sterring problems , but i do know the outer cv joints on the front axles will make it seem to lock up if they are dry or bad ,seems highly unlikley since the machine is so new , but stranger things have happened
__________________
06 650i, 29.5 skinny laws,warn 3000 winch,relocated rad,oil cooler,oil press ,water temp,an oil temp gauges, fst 85mm 11.5 to 1,fst stage2 cams,dynafs ing,head porting,front mounted reciver hitch(works well moving trailers) full hmf exhaust .rmax manual 4wd, ez steer
rmax is online now   Reply With Quote
Old August 30th, 2011, 08:25 AM   #3
DLB
 
DLB's Avatar
 
Join Date: Oct 2009
Location: WV
Posts: 1,062
Thanks: 4
Thanked 46 Times in 43 Posts
Default

That's a first for me too. The 12' Brute is a new design, but not so removed from the previous design that there should be bugs to work out. What kind of oil are you using in the front diff?
__________________
Teryx4 EPS | Suzuki LT80 | Brute Force 750
...and several others since 1988

My Garage

YouTube links:
DLB | ElkRiverOffRoad
DLB is offline   Reply With Quote
Old August 30th, 2011, 08:54 AM   #4
 
NMKAWIERIDER's Avatar
 
Join Date: Aug 2008
Location: Albuquerque, NM
Posts: 9,745
Thanks: 5
Thanked 514 Times in 466 Posts
Default

New to me too...no one on any other site I visit has had any issues with the 12 even on MIMB. I would say its something they are not looking at...maybe electrical not machanical. It is speed controled so maybe a bad speed sensor or connection. Somthing simple probably.
__________________
06 750 (Silver)
EZ-Steer EPS | Elka Stage-3 Shocks | Dynatek CDI |UNIfilter Filter | Catch Can | Perma-Cool Oil Cooler | Diamond "G" Tie Rods w/Moose Ends | Energy Swaybar Bushings | OMI Stem Bushing | Ricochet Skid Plates | HL Bumper | Direction2 Overfenders | 26" Grim Reapers on 14" SS112s | 2012 Seat | 2013 A-Arms & Bushings| Shorai Battery | ROX Riser & guards | Tons More Stuff!


NMKAWIERIDER is online now   Reply With Quote
Old August 30th, 2011, 09:35 PM   #5
 
Fordgasm250's Avatar
 
Join Date: Aug 2011
Location: Va
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not to sure what kind of oil they put it in, i mean its a brand new front diff just installed aweek ago by dealership under warranty, rode 10 miles and broke again, theyve replaced the power steering unit and 4 wheel drive actuator already to, i havent put it in 4wd either time so yalls guess is good as mine
__________________
2012 750 brute 14 in SS212 wheels, 27" itp terra cross, hmf swamp series exhaust, hmf efi optimizer, k&n filter
Fordgasm250 is offline   Reply With Quote
Old August 31st, 2011, 08:59 AM   #6
 
rmax's Avatar
 
Join Date: Jul 2010
Location: ne arkansas, south miss
Posts: 727
Thanks: 0
Thanked 27 Times in 27 Posts
Default

do they have a lemon law in your state,
__________________
06 650i, 29.5 skinny laws,warn 3000 winch,relocated rad,oil cooler,oil press ,water temp,an oil temp gauges, fst 85mm 11.5 to 1,fst stage2 cams,dynafs ing,head porting,front mounted reciver hitch(works well moving trailers) full hmf exhaust .rmax manual 4wd, ez steer
rmax is online now   Reply With Quote
Old August 31st, 2011, 09:29 PM   #7
 
Fordgasm250's Avatar
 
Join Date: Aug 2011
Location: Va
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yea we are looking into the lemon law, i think it has to break 3 times for it to fall in affect
__________________
2012 750 brute 14 in SS212 wheels, 27" itp terra cross, hmf swamp series exhaust, hmf efi optimizer, k&n filter
Fordgasm250 is offline   Reply With Quote
Old September 2nd, 2011, 06:36 PM   #8
 
12bf's Avatar
 
Join Date: Jul 2011
Location: central pa
Posts: 128
Thanks: 9
Thanked 2 Times in 2 Posts
Default

I have a 2012 brute works great so far, Let us know when they find out whats wrong that would be good some good info right there.
__________________
2012 Brute 750 eps se
Terracross 25x10x12
Terracross 25x8x12
1" Spacers
Uni filter

My videos...
12bf is offline   Reply With Quote
Old September 5th, 2011, 10:20 PM   #9
 
Fordgasm250's Avatar
 
Join Date: Aug 2011
Location: Va
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

just a update guys i found both front axles broke, so took it back to kawasaki they say it was a new problem but im thinking its been that all along, the joints are broke and only way to see is if ya remove the axle boots like i did
__________________
2012 750 brute 14 in SS212 wheels, 27" itp terra cross, hmf swamp series exhaust, hmf efi optimizer, k&n filter
Fordgasm250 is offline   Reply With Quote
Old September 6th, 2011, 08:16 AM   #10
 
STOGI's Avatar
 
Join Date: Oct 2006
Posts: 195
Thanks: 1
Thanked 4 Times in 3 Posts
Default

My question is how could broke axles interfere with the powersteering? Not saying it couldn't .. I'm just interested in how.
__________________
BF750 Built For Business
Stock is for pansies.

STOGI is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Brute Central Forums » Brute Forums » Brute Chassis & Electrical


Search tags for this page

2011 brute force 750 problems

,
2011 kawasaki brute force 750 problems
,
2012 brute force 750 oil filter
,
2012 brute force 750 power steering problems
,

2012 brute force 750 problems

,
2012 brute force problems
,
2012 kawasaki 750 brute force problems
,

2012 kawasaki brute force 750 problems

,
brute force 750 forum
,
brute force 750 problems
,
brute force steering problems
,
kawasaki brute force 750 problems
Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:00 PM.

Website by Be Seen.


SEO by vBSEO ©2011, Crawlability, Inc.